¿Por qué actualizar a WordPress 3.1.2?

 

Desde hace 2-3 días (depende de la ubicación) hemos empezado a ver en nuestro dashboard de WordPress un mensaje para actualizar a la versión 3.1.2

 

wordpress 3.1.2

Y la pregunta para quienes trabajamos en WordPress debe ser el porqué de esta nueva versión, qué nos trae y qué nos evita.

Multiple tag queries broken

Tras un reporte que dice que al realizar un query de forma tales.com/tag/tag1+tag2/ respondía con 404 en la versión de WordPress 3.1.1 la solución se dio cuando en el archivo wp-includes/query.php se cambio un uso incorrecto del operador sobre taxonomías, detalles en http://core.trac.wordpress.org/changeset/17611

WP_User_Query ordered by post_count doesn’t work if prefix is not wp_

Este es el que se puede llamar “El Bug”, y se resume que al parecer en el archivo wp-includes/user.php, en la línea 441 alguien introdujo el nombre de la tabla wp_posts en una sentencia en lugar de $wpdb->posts. ¿Qué significa esto? Que nuestro WordPress estaría metiéndose en datos de otra instalación o, en el mejor de los casos, funcionaría mal.

Walker_PageDropdown doesn’t filter titles correctly

Es un mal funcionamiento del filtro en los títulos, sólo se alteraron un par de líneas, http://core.trac.wordpress.org/changeset/17685

Too much escaping for pages when using Quick Edit

Este cambio previene que se sobreescape el título de las páginas.

Validate post status against capabilities in press this

Éste es el importante, un bug de seguridad. Permitía a un usuario con el rango “Colaborador” publicar contenidos.